AlphaServer

Garbage and Things

Ubuntu: Instalar Flash Player 9 at AMD64

Posted by alphaserver em Maio 21, 2007


Visitem

Novo site: alphaserver.exofire.net

Introdução

Manual para instalar o Flash Player 9 no AMD64bits.

Em 32bits é bastante fácil, mas em 64bits é diferente e é o que este guia pretende ajudar e mostrar. Em primeiro vamos instalar uma série de livrarias compatíveis com 32bits, ou seja as dependências.

1. Executar o comando para instalar as dependências

$ sudo apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2

2. Agora fazer os seguintes downloads

http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-0.9.91.2-1.x86_64.rpm
http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-i386-0.9.91.2-1.x86_64.rpm

3. Executar os seguintes comandos

$ sudo apt-get install alien
$ sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm
$ sudo alien nspluginwrapper-i386-0.9.91.2-1.x86_64.rpm
$ sudo dpkg -i nspluginwrapper-0.9.91.2-1.x86_64.deb
$ sudo dpkg -i nspluginwrapper-i386-0.9.91.2-1.x86_64.deb

4. Após isso o Download do Flash

Fazer o download do tar.gz Flash Player 9 do site do Adobe:

http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash

Extrair os ficheiros para uma pasta.

5. Correr o nspluginwrapper

Copiar os ficheiros “libflashplayer.so” e “flashplayer.xpt” para /usr/lib/mozilla-firefox/plugins/

Desligar o Firefox e executar o seguinte comando:

$ nspluginwrapper -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so

Agora o Flash já deve funcionar correctamente!

30 Respostas to “Ubuntu: Instalar Flash Player 9 at AMD64”

  1. Carlos Eduardo Wagner said

    Caro Alphaserver:

    Executei as instruções conforme relacionado e deu a mensagem de erro abaixo. Sabes o que pode ter acontecido?
    Grato,
    Wagner

    root@desktop:~# nspluginwrapper -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so
    nspluginwrapper: /usr/lib/mozilla-firefox/plugins/libflashplayer.so is not a valid NPAPI plugin
    root@desktop:~#

  2. alphaserver said

    Carlos, executas-te o seguinte comando?:

    sudo apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2

    ou entao:

    mover ou copiar o plugin (libflashplayer.so) para: /usr/lib/mozilla/plugins

    e depois na consola:

    sudo /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so

  3. Carlos Eduardo Wagner said

    Alphaserver, boa noite.
    Verifique a situação no sistema. Estou colando o resultado dos comandos abaixo. Não funcionou.
    Grato,
    Wagner

    root@desktop:/usr/lib/mozilla-firefox/plugins# apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2
    Lendo Lista de Pacotes… Pronto
    Construindo Árvore de Dependências
    Lendo informação de estado… Pronto
    ia32-libs já é a versão mais nova.
    ia32-libs-gtk já é a versão mais nova.
    linux32 já é a versão mais nova.
    lib32asound2 já é a versão mais nova.
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

    root@desktop:/usr/lib/mozilla-firefox/plugins# ls -l
    total 6904
    -rwxrwxrwx 1 edu edu 856 2007-05-29 22:05 flashplayer.xpt
    -rwxrwxrwx 1 root root 7040080 2007-05-29 22:05 libflashplayer.so
    lrwxrwxrwx 1 root root 36 2007-05-03 19:01 libtotem-basic-plugin.so -> ../../totem/libtotem-basic-plugin.so
    lrwxrwxrwx 1 root root 37 2007-05-03 19:01 libtotem-basic-plugin.xpt -> ../../totem/libtotem-basic-plugin.xpt
    lrwxrwxrwx 1 root root 34 2007-05-03 19:01 libtotem-gmp-plugin.so -> ../../totem/libtotem-gmp-plugin.so
    lrwxrwxrwx 1 root root 35 2007-05-03 19:01 libtotem-gmp-plugin.xpt -> ../../totem/libtotem-gmp-plugin.xpt
    lrwxrwxrwx 1 root root 36 2007-05-03 19:01 libtotem-mully-plugin.so -> ../../totem/libtotem-mully-plugin.so
    lrwxrwxrwx 1 root root 37 2007-05-03 19:01 libtotem-mully-plugin.xpt -> ../../totem/libtotem-mully-plugin.xpt
    lrwxrwxrwx 1 root root 42 2007-05-03 19:01 libtotem-narrowspace-plugin.so -> ../../totem/libtotem-narrowspace-plugin.so
    lrwxrwxrwx 1 root root 43 2007-05-03 19:01 libtotem-narrowspace-plugin.xpt -> ../../totem/libtotem-narrowspace-plugin.xpt
    -rw-r–r– 1 root root 11072 2007-04-03 12:30 libunixprintplugin.so

    root@desktop:/usr/lib/mozilla-firefox/plugins# /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so
    root@desktop:/usr/lib/mozilla-firefox/plugins#

  4. Beto said

    Parabens amigo funcionou perfeitamente

  5. Carlos Eduardo Wagner said

    Caro Alphaserver

    Refiz a lista de procedimentos e funcionou. Devo ter feito algo errado antes.

    Grato e parabéns.

    Wagner

  6. Turin said

    Aconselho o pessoal a verificar o nome dos ficheiros , especialmente os traços.
    No meu computador funcionou à segunda porque da primeira vez copiei as frases todas mas no meu computador os ficheiros ( deb ) criados tinham nomes diferentes.
    Quando fiz tudo de novo confirmando os nomes que tinham sido criados na minha pasta (home) funcionou logo.

    Obrigado pela dica alphaserver !!!!

  7. Paulo said

    Olá Alphaserver! Acompanhei o tutorial até esse passo:

    sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm

    Depois que dei enter apareceu a seguinte mensagem:

    Warning: Skipping conversion of scripts in package nspluginwrapper: postinst prerm
    Warning: Use the –scripts parameter to include the scripts.
    nspluginwrapper_0.9.91.2-2_amd64.deb generated

    Meu PC é um Pentium 4 HT, Nvidia 6600 GT, 1GB de ram e tenho o Ubuntu instalado.

    Os passos anteriores deram certo, até chegar a esse que reportei.

    Você sabe o q pode estar acontecendo??? Agradeço desde já!

  8. alphaserver said

    Paulo, o tutorial não se pode aplicar ao teu pc… não tens um AMD64 mas sim um Pentium 4… para instalares o FlashPlayer num pc que não seja AMD64 é diferente.

  9. Paulo said

    Sabes qual o procedimento ou onde posso conseguir um tutorial que explique?

  10. Mário said

    oi, fiz tudo so naum consigo fazer o 5 passo

    Copiar os ficheiros “libflashplayer.so” e “flashplayer.xpt” para /usr/lib/mozilla-firefox/plugins/

    como posso me dar a permissao de root na pasta??

  11. Diogo said

    Valeu!!!!!!

    Instalação perfeita já tinha umas 3 horas que eu estava procurando um tutorial descente, o seu foi o melhor q achei.

    Obrigado!

  12. Diogo said

    Mário,

    Comigo não houve a necessidade do passo 5, foi automático, entra em /usr/lib/mozilla-firefox/plugins/ e olha se os arquivos já estão lá, se tiver pula para a parte de comando nspluginwrapper -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so

    Espero ter ajudado.

  13. Mário said

    oi, consegui mover os arkivos
    so q qdo digito
    $ nspluginwrapper -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so

    aparece so isso
    bash: nspluginwrapper: comando não encontrado

    q q ta errado??

  14. jeferson said

    Amigão essa foi d+, fiz o passa a passo e voila…. td funcionando ok.
    Obrigado mesmo pela dica. Valeu.

  15. Joel Cf said

    Oi,

    Fiz tudo passo a passo e nunca me deu erro, mas por alguma razao o flash continua a nao estar instalado no firefox…..

    apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    ia32-libs is already the newest version.
    ia32-libs-gtk is already the newest version.
    linux32 is already the newest version.
    lib32asound2 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    sudo /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so

    nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

    e tambem

    sudo /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so

    nspluginwrapper -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so

    Nada…..

    Alguma ideia??

  16. Fernando said

    deu problema aki, alguem pode me ajudar?!

    sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm

    Warning: Skipping conversion of scripts in package nspluginwrapper: postinst prerm
    Warning: Use the –scripts parameter to include the scripts.
    nspluginwrapper_0.9.91.2-2_amd64.deb generated

    Uso um Turion 64 X2.
    Ubuntu 7.04

    Valeu

  17. Paulo Almeida said

    Segui todos os passos sem problemas, à execeção dos “warnings” já relatados no uso do comando “alien”. Mas os arquivos .deb foram criados e instalados sem mensagem de erro. No entanto, ao abrir o firefox de um console, recebo os seguintes erros (o plugin não foi instalado):

    pema@ubuntu:~$ firefox
    X Error: BadDevice, invalid or uninitialized input device 167
    Major opcode: 144
    Minor opcode: 3
    Resource id: 0x0
    Failed to open device
    X Error: BadDevice, invalid or uninitialized input device 167
    Major opcode: 144
    Minor opcode: 3
    Resource id: 0x0
    Failed to open device
    LoadPlugin: failed to initialize shared library /usr/lib/firefox/plugins/libflashplayer.so [/usr/lib/firefox/plugins/libflashplayer.so: wrong ELF class: ELFCLASS32]

    Alguma idéia do que pode estar errado? Obrigado pelo tutorial e pela atenção.
    Paulo

  18. danilo said

    cmg deu problema nos 2 DPKG:

    danilo@danilo-desktop:~$ sudo dpkg -i nspluginwrapper-0.9.91.2-1.x86_64.deb
    dpkg: erro processando nspluginwrapper-0.9.91.2-1.x86_64.deb (–install):
    impossível acessar arquivo: Arquivo ou diretório inexistente
    Erros foram encontrados durante processamento de:
    nspluginwrapper-0.9.91.2-1.x86_64.deb

    Oq ser isso? :S

  19. danilo said

    Ah os arquivos .deb estao com nomes diferentes!! Acho q mais atualizados ^^
    vlw..

  20. Caua said

    o meu ocorre o erro no alien porem todos os proximos passos sao executados sem mensagem alguma, porem nao funciona, alguem pode me ajudar.
    cauasiqueira@yahoo.com.br

    root@caua-laptop:/home/caua# sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm
    Warning: Skipping conversion of scripts in package nspluginwrapper: postinst prerm
    Warning: Use the –scripts parameter to include the scripts.
    nspluginwrapper_0.9.91.2-2_amd64.deb generated

  21. Ieso Nagata said

    Yo!
    estou num lenny64 (debian testing) e esses passos todos foram automaticamente efetuados pela simples instalação do flashplayer-mozilla

    $sudo aptitude install flashplayer-mozilla

    havendo somente a necessidade do

    $sudo nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

    em “About:plugins”
    Shockwave Flash

    Nome do arquivo: npwrapper.libflashplayer.so
    Shockwave Flash 9.0 r31

    that’s it!

  22. caua said

    Rapaziada,

    O meu continua sem funcionar, toda pagina que entro pede para instalar o shockwave. Ja fiz todos os passos acima, porem ainda sem sucesso.

    Obrigado !!!!

  23. Luis said

    Funcionou perfeitamente para mim.
    Muito obrigado.

  24. Ewerton said

    Funcionou no mandriva, mas estou sem som no youtube..alguma dica?

  25. Marcelo Cardelli de Cmargo said

    Cara, muito Obrigado!!!
    Funcionou muito bem no meu swiftfox, o navegador ficou muito rápido!!

    Tive que instala-lo devido ao firefox 2 ão funcionar de jeito nenhum!!

    Por que será que pra plataforma amd-64 é tão complicado?? rsrs!!

    Vc poderia me explicar pra que serve o Software nspluginwrapper?

    Não entendi seu funcionamento.

  26. Anónimo said

    algo errado….
    quando extraio os arquivos do flash obtenho:
    install-flash-player-9-linux_1-2_all.deb

    com faço para obter os libflashplayer.so” e “flashplayer.xpt”?

  27. Anónimo said

    agora deu certo!!!!

  28. tulio said

    olá!
    sigo os passos até:$ sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm
    que aparece um erro:
    tulio@tulio-desktop:~$ sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm
    sudo: alien: command not found
    tulio@tulio-desktop:~$

    o q faço?

  29. Daniel said

    Para quem está recebendo a mensagem de erro:
    Warning: Skipping conversion of scripts in package nspluginwrapper: postinst prerm

    Verifique que o arquivo “nspluginwrapper-0.9.91.2-1.x86_64.rpm” quando transformado em deb tem ao invés de um hífen um underline depois de nspluginwrapper ficando “nspluginwrapper_0.9.91.2-2_amd64.deb”

    Cuidado se você for só copiar e colar!

    Abraço,
    Daniel

  30. Claudio said

    Executei os passos e não funcionou. Já esto com o FF 3 no meu Ubuntu 7.10.

    Então copiei o libflashplayer.so para /usr/lib/firefox/plugins e executei

    sudo su nspluginwrapper -i /usr/lib/firefox/plugins/libflashplayer.so

    Está funcionando perfeitamente!!!

Deixe uma Resposta

Preencha os seus detalhes abaixo ou clique num ícone para iniciar sessão:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s

 
%d bloggers like this: